<!doctype html>
<html class="no-js" lang="">
<head>
  <meta charset="utf-8">
  <meta http-equiv="x-ua-compatible" content="ie=edge">
  <title>Finally?: A Frisbee With An HD Camera Attached - Geekologie</title>
  <meta name="description" content=" Muscles: apparently you need them to play with this. Brookstone, best known for their vibrating massage chairs everyone has sat in at the mall but nobody actually owns, is selling this $60 VFO (Video Flying Object) with 720P HD..." />
  <meta name="viewport" content="width=device-width, initial-scale=1">

  <meta property="og:title" content="Finally?: A Frisbee With An HD Camera Attached" />
  <meta property="og:site_name" content="Geekologie" />
  <meta property="og:url" content="http://geekologie.com/2017/07/finally-a-frisbee-with-an-hd-camera-atta.php" />
  <meta property="og:description" content=" Muscles: apparently you need them to play with this. Brookstone, best known for their vibrating massage chairs everyone has sat in at the mall but nobody actually owns, is selling this $60 VFO (Video Flying Object) with 720P HD..." />
  <meta property="og:image" content="http://geekologie.com/2017/07/11/video-camera-frisbee.jpg" />
  <meta property="og:type" content="article" />

  <meta name="twitter:card" content="summary_large_image" />
  <meta name="twitter:site" content="@geekologie">
  <meta name="twitter:creator" content="@geekologie">
  <meta name="twitter:url" content="http://geekologie.com/2017/07/finally-a-frisbee-with-an-hd-camera-atta.php" />
  <meta name="twitter:title" content="Finally?: A Frisbee With An HD Camera Attached" />
  <meta name="twitter:description" content=" Muscles: apparently you need them to play with this. Brookstone, best known for their vibrating massage chairs everyone has sat in at the mall but nobody actually owns, is selling this $60 VFO (Video Flying Object) with 720P HD...">
  <meta name="twitter:image:src" content="http://geekologie.com/2017/07/11/video-camera-frisbee.jpg" />
  
  <meta property="article:publisher" content="https://www.facebook.com/geekologie" />

<link rel="alternate" type="application/atom+xml" title="Atom" href="/atom.xml" />
  <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="/index.xml" />
  <link href='https://fonts.googleapis.com/css?family=Open+Sans:400,700|Oswald:400,300,700|Droid+Serif:400,700,400italic,700italic' rel='stylesheet' type='text/css'>
  <link rel="stylesheet" href="/v5/css/global.css?v=5.25" media="all">
  <script src="https://cdnjs.cloudflare.com/ajax/libs/modernizr/2.8.3/modernizr.min.js"></script>
  <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>

<script async type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];

googletag.cmd.push(function() {
googletag.defineSlot('/1039157/Geekologie_Home_160x600', [160, 600], 'div-gpt-ad-1420723716929-0').addService(googletag.pubads());
googletag.defineSlot('/1039157/Geekologie_Home_300x250', [300, 250], 'div-gpt-ad-1420723716929-1').addService(googletag.pubads());
googletag.defineSlot('/1039157/Geekologie_Home_300x250_BTF', [300, 250], 'div-gpt-ad-1420723716929-2').addService(googletag.pubads());
googletag.defineSlot('/1039157/Geekologie_Home_728x90_top', [728, 90], 'div-gpt-ad-1420723716929-3').addService(googletag.pubads());
googletag.defineSlot('/1039157/Geekologie_Home_728x90_bottom', [728, 90], 'div-gpt-ad-1420723716929-4').addService(googletag.pubads());
googletag.defineSlot('/1039157/Geekologie_Home_970x90', [[728, 90], [970, 90]], 'div-gpt-ad-1420723716929-5').addService(googletag.pubads());
googletag.defineSlot('/1039157/Geekologie_ROS_160x600', [160, 600], 'div-gpt-ad-1420723716929-6').addService(googletag.pubads());
googletag.defineSlot('/1039157/Geekologie_ROS_300x250', [300, 250], 'div-gpt-ad-1420723716929-7').addService(googletag.pubads());
googletag.defineSlot('/1039157/Geekologie_ROS_300x250_BTF', [300, 250], 'div-gpt-ad-1420723716929-8').addService(googletag.pubads());
googletag.defineSlot('/1039157/Geekologie_ROS_728x90_top', [728, 90], 'div-gpt-ad-1420723716929-9').addService(googletag.pubads());
googletag.defineSlot('/1039157/Geekologie_ROS_728x90_Bottom', [728, 90], 'div-gpt-ad-1420723716929-10').addService(googletag.pubads());
googletag.defineSlot('/1039157/Geekologie_ROS_970x90', [[728, 90], [970, 90]], 'div-gpt-ad-1420723716929-11').addService(googletag.pubads());

});
</script>
<script type="text/javascript" id="nsgpt" data-channel="homepage" src="//cdn.nsstatic.net/ns/geekologie.com.js" async="true"></script>
</head>
<body>
<div id="ros_adoop"></div>
<header class="global-header">
  <ul class="network-wrap">
    <li class="network-site"><a href="//hedonistica.com">Hedonistica</a></li>
    <li class="network-site"><a href="//iwatchstuff.com">I Watch Stuff</a></li>
  </ul>
  <a href="/"><div class="logo"><img src="/v5/img/geekologie-logo.png" border="0"></div></a>
</header>

<nav class="global-nav">
  <ul class="nav-wrap">
    <a href="/"><li class="nav-button">Home</li></a>
    <a href="/videos/"><li class="nav-button hidden-sm">Videos</li></a>
    <a href="/video-games/"><li class="nav-button hidden-sm">Video Games</li></a>
    <a href="/archives.php"><li class="nav-button">Archives</li></a>
    <a href="/contact/"><li class="nav-button hidden-sm">Send a Tip!</li></a>
    <a href="https://facebook.com/geekologie"><li class="nav-button-fb">Facebook</li></a>
    <a href="https://twitter.com/geekologie"><li class="nav-button-twitter">Twitter</li></a>
    <li class="search-wrap">
      <form method="get" action="/mt/mt-search.cgi">
        <button class="searchButton"></button>
        <input type="text" name="search" value="" placeholder="Search..."/>
      </form>
    </li>
  </ul>
</nav>

<div class="ad-wrap-atf">
  <div class="leaderboard-ad-atf"><div data-ns="billboard"></div>
</div>
</div>

<div class="wrap">
  <div class="content">
    <article class="post">
      <header class="post-header">
        <h1><a href="http://geekologie.com/2017/07/finally-a-frisbee-with-an-hd-camera-atta.php">Finally?: A Frisbee With An HD Camera Attached</a></h1>
        <div class="meta">July 11, 2017 <a href="#comments-wrap"><div class="comment-count"><script type='text/javascript' src='http://disqus.com/forums/geekologie/get_num_replies_for_entry.js?url=http://geekologie.com/2017/07/finally-a-frisbee-with-an-hd-camera-atta.php'></script><noscript>View</noscript></div></a></div>
      </header>

      <p><img alt="video-camera-frisbee.jpg" src="http://geekologie.com/2017/07/11/video-camera-frisbee.jpg" width="640" height="531" class="mt-image-none" style="" /></p>

<p>Muscles: apparently you need them to play with this.</p>

<p>Brookstone, best known for their vibrating massage chairs everyone has sat in at the mall but nobody actually owns, is selling this <a href="http://www.brookstone.com/pd/vfo-video-flying-object-with-720p-hd-video-camera/317858p.html">$60 VFO (Video Flying Object) with 720P HD Video Camera</a>.  The camera does not record audio, which is probably a good thing considering it would just sound like a wind tunnel.  Alternatively, tape your GoPro to an existing frisbee.  That's what I did.  "And?"  And now it's on my neighbor's roof and they're not answering their door.  There's a video after the jump of a couple hunks and a babe tossing the frisbee around on the beach that includes about two seconds of actual footage from the frisbee cam, which can only be describes as "extremely underwhelming" and "I want my money back."  Of course nobody got hit in the teeth so that might have had something to do with it.</p>

<p>Keep going for the video while I try to grappling hook up to my neighbor's roof.</p>
      <div class="videowrap"><iframe width="640" height="420" src="https://www.youtube.com/embed/6ywLQqP5M1M" frameborder="0" allowfullscreen></iframe></div>

<p>Thanks to blue16, who agrees the only purpose of a frisbee camera is to run around intentionally trying to hit your friends with it.</p>

      <div class="share-buttons">
        <a href="https://facebook.com/sharer/sharer.php?text=Finally?: A Frisbee With An HD Camera Attached&amp;u=http://geekologie.com/2017/07/finally-a-frisbee-with-an-hd-camera-atta.php" class="fb-circle">Facebook</a>
        <a href="https://twitter.com/intent/tweet?counturl=http://geekologie.com/2017/07/finally-a-frisbee-with-an-hd-camera-atta.php&amp;text=Finally?: A Frisbee With An HD Camera Attached&amp;url=http://geekologie.com/2017/07/finally-a-frisbee-with-an-hd-camera-atta.php&amp;via=geekologie" class="twitter-circle">Twitter</a>
        <a href="http://www.pinterest.com/pin/create/button/?description=Finally?: A Frisbee With An HD Camera Attached&amp;media=http://geekologie.com/2017/07/11/video-camera-frisbee.jpg&amp;url=http://geekologie.com/2017/07/finally-a-frisbee-with-an-hd-camera-atta.php" class="pinterest-circle">Pinterest</a>
      </div>

      <div class="row">
        <div class="col col-6">
          
          <!-- post-wide.mtml -->
          <div class="post-wide">
            <a href="http://geekologie.com/2017/07/freaky-deaky-timelapse-of-a-dragonflys-m.php">
            
              <div class="post-wide-thumb image" style="background-image:url('http://geekologie.com/2017/07/10/dragonfly-metamorphosis.jpg')"><img src="http://geekologie.com/2017/07/10/dragonfly-metamorphosis.jpg">
                
                <div class="icon-video"></div>
                
              </div>
            
            
          </a>
            <div class="post-wide-copy">
              <h3><a href="http://geekologie.com/2017/07/freaky-deaky-timelapse-of-a-dragonflys-m.php">Freaky Deaky: Timelapse Of A Dragonfly Emerging</a></h3>
              <div class="nav-meta">Previous Story</div>
            </div>
          </div>
          <!-- /post-wide -->
          
        </div>

        <div class="col col-6">
          
          
          <!-- post-wide.mtml -->
          <div class="post-wide">
            <a href="http://geekologie.com/2017/07/caution-hero-at-work-a-batman-cape-for-y.php">
            
              <div class="post-wide-thumb image" style="background-image:url('http://geekologie.com/2017/07/11/batman-office-chair-cape.jpg')"><img src="http://geekologie.com/2017/07/11/batman-office-chair-cape.jpg">
                
                
                
                
              </div>
            
            
          </a>
            <div class="post-wide-copy">
              <h3><a href="http://geekologie.com/2017/07/caution-hero-at-work-a-batman-cape-for-y.php">Caution, Hero At Work: A Batman Cape For Your Office Chair</a></h3>
              <div class="nav-meta">Next Story</div>
            </div>
          </div>
          <!-- /post-wide -->
          
          
        </div>
      </div>

      <div class="post-summary">
        <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
        <script>
          var googletag = googletag || {};
          googletag.cmd = googletag.cmd || [];
        </script>
        <div id='div-pg-ad-1488273004-2'>
          <script type='text/javascript'>
                googletag.cmd.push(function() { googletag.pubads().display('/8095840/95.geekologie.com_desktop_300x250_BTF', [300, 250], 'div-pg-ad-1488273004-2'); });
          </script>
        </div>
      </div>

      <section id="comments-wrap">
                        <link rel="stylesheet" href="http://disqus.com/stylesheets/geekologie/disqus.css?v=2.0" type="text/css" media="screen" />
                
<div id="disqus_thread">
	<div id="dsq-content">
		<ul id="dsq-comments">
		</ul>
	</div>
</div>

<a href="http://disqus.com" class="dsq-brlink">blog comments powered by <span class="logo-disqus">Disqus</span></a>

<script type="text/javascript" charset="utf-8">
	var disqus_url = 'http://geekologie.com/2017/07/finally-a-frisbee-with-an-hd-camera-atta.php ';
	var disqus_container_id = 'disqus_thread';
	var facebookXdReceiverPath = '/mt/mt-static/plugins/disqus/xd_receiver.htm';
</script>

<!-- d tb code was here -->

<script type="text/javascript" charset="utf-8" src="http://disqus.com/scripts/geekologie/disqus.js?v=2.0&slug=finally_a_frisbee_with_an_hd_camera_attached&pname=movabletype&pver=2.0"></script>

      </section>

      <div class="tag-wrap">
        <span class="tag-label">Read More:</span> <a href="/tag/brookstone" class="tags">brookstone</a>, <a href="/tag/camera" class="tags">camera</a>, <a href="/tag/different strokes for different folks" class="tags">different strokes for different folks</a>, <a href="/tag/hammacher schlemmer where were you on this?" class="tags">hammacher schlemmer where were you on this?</a>, <a href="/tag/having an underwhelming time" class="tags">having an underwhelming time</a>, <a href="/tag/hunks and babes" class="tags">hunks and babes</a>, <a href="/tag/iffy" class="tags">iffy</a>, <a href="/tag/now i'm going to flood my social media account with frisbee vids!" class="tags">now i'm going to flood my social media account with frisbee vids!</a>, <a href="/tag/questionable" class="tags">questionable</a>, <a href="/tag/real products that exist" class="tags">real products that exist</a>, <a href="/tag/throwing things" class="tags">throwing things</a>, <a href="/tag/to the beach" class="tags">to the beach</a>, <a href="/tag/toys" class="tags">toys</a>, <a href="/tag/video" class="tags">video</a>, <a href="/tag/whatever" class="tags">whatever</a>
      </div>
    </article>

  </div>

  <div class="sidebar">
  <div class="atf-sticky">
    <div class="rectangle-ad-atf"><div data-ns="halfpage"></div></div>

    <!-- sidebar.mtml -->
    <ul class="side-wrap">
      <h4><span>Related</span></h4>
      <div class="post-wide">
  <a href="http://geekologie.com/2017/06/roomba-allegedly-takes-wagon-full-of-stu.php">
  
    <div class="post-wide-thumb image" style="background-image:url('http://geekologie.com/2017/06/29/roomba-stuffed-animal-wagon.jpg')"><img src="http://geekologie.com/2017/06/29/roomba-stuffed-animal-wagon.jpg">
      
      <div class="icon-video"></div>
      
    </div>
  
  
</a>
  <div class="post-wide-copy">
    <h3><a href="http://geekologie.com/2017/06/roomba-allegedly-takes-wagon-full-of-stu.php">Roomba Allegedly Takes Wagon Full Of Stuffed Animals On House Tour By Itself</a></h3>
    <div class="meta">June 29, 2017</div>
  </div>
</div><div class="post-wide">
  <a href="http://geekologie.com/2017/06/autonomous-rock-balancing-robot-can-make.php">
  
    <div class="post-wide-thumb image" style="background-image:url('http://geekologie.com/2017/06/06/rock-stacking-robot.jpg')"><img src="http://geekologie.com/2017/06/06/rock-stacking-robot.jpg">
      
      <div class="icon-video"></div>
      
    </div>
  
  
</a>
  <div class="post-wide-copy">
    <h3><a href="http://geekologie.com/2017/06/autonomous-rock-balancing-robot-can-make.php">Autonomous Rock Balancing Robot Can Make Stacked Rock Sculptures</a></h3>
    <div class="meta">June  6, 2017</div>
  </div>
</div><div class="post-wide">
  <a href="http://geekologie.com/2017/05/real-products-that-exist-666-alcohol-hel.php">
  
    <div class="post-wide-thumb image" style="background-image:url('http://geekologie.com/2017/05/24/hellboy-cinnamon-whiskey.jpg')"><img src="http://geekologie.com/2017/05/24/hellboy-cinnamon-whiskey.jpg">
      
      
      
      
      
    </div>
  
  
</a>
  <div class="post-wide-copy">
    <h3><a href="http://geekologie.com/2017/05/real-products-that-exist-666-alcohol-hel.php">Real Products That Exist: 66.6% Alcohol Hellboy 'Hellfire' Cinnamon Whiskey</a></h3>
    <div class="meta">May 24, 2017</div>
  </div>
</div>
    </ul>

    <div class="side-wrap">
      <div class="rectangle-ad-atf"><div data-ns="rectangle"></div></div>
    </div>
    <!-- /sidebar -->
  </div>
  </div>
</div>

<a href="http://geekologie.com/2017/07/freaky-deaky-timelapse-of-a-dragonflys-m.php"><div class="prev-arrow">Previous Post</div></a>

  <a href="http://geekologie.com/2017/07/caution-hero-at-work-a-batman-cape-for-y.php"><div class="next-arrow">Next Post</div></a>


<div class="ad-wrap-btf container">
  <div class="leaderboard-ad-btf"><script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1488272297-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/95.geekologie.com_desktop_728x90_2', [728, 90], 'div-pg-ad-1488272297-3'); });
  </script>
</div></div>
</div>

  <footer class="global-footer container">
    <ul>
      <li>© 2017 Anticlown Media LLC</li>
      <li><a href="/">Home</a></li>
      <li><a href="/about/">About</a></li>
      <li><a href="/archives.php">Site Map</a></li>
      <li><a href="/contact/">Contact</a></li>
      <li><a href="/atom.xml">Atom</a></li>
      <li><a href="/index.xml">RSS</a></li>
    </ul>
  </footer>

  <script async type="text/javascript">
  window.ZDStickyOpts = function() {
    return {
      topLeaderboardAdContainer: '',
      sidebarTopAdContainer: '.atf-sticky',
      sidebarBottomAdContainer: '',
      pageContent: '.wrap',
      fixedNavBar: '',
      unstickOnViewable: 'ALL'
    }
  }
  </script>
  <script async type="text/javascript" src="http://cdn.ziffstatic.com/jst/zdsticky.rel.js?v=1" async="async"></script>

  <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    ga('create', 'UA-96613-3', 'auto');
    ga('send', 'pageview');

  </script>
</body>
</html>
